summary refs log tree commit diff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:05:30 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:50 -0400
commit7e7df095d73257eb417c87088cbf616c11362e1e (patch)
tree43bf83502f18fd392eba5e4f7a607a06aae94597 /gnu/packages/syncthing.scm
parent63950f9b39c1c20c2ca88f53518e898739e3c160 (diff)
downloadguix-7e7df095d73257eb417c87088cbf616c11362e1e.tar.gz
gnu: Add go-golang-org-x-crypto-salsa20.
* gnu/packages/syncthing.scm (go-golang-org-x-crypto-salsa20): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 5cf9b95592..c421c9528d 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -836,6 +836,43 @@ Algorithm (TEA) block cipher.")
       (home-page "https://go.googlesource.com/crypto/")
       (license bsd-3))))
 
+(define-public go-golang-org-x-crypto-salsa20
+  (let ((commit "c78caca803c95773f48a844d3dcab04b9bc4d6dd")
+        (revision "0"))
+    (package
+      (name "go-golang-org-x-crypto-salsa20")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://go.googlesource.com/crypto")
+                      (commit commit)))
+                (file-name (string-append "go.googlesource.com-crypto-"
+                                          version "-checkout"))
+                (sha256
+                 (base32
+                  "0vxlfxr9y681yn2cfh6dbqmq35vvq4f45ay0mm31ffkny9cms0y4"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "golang.org/x/crypto/salsa20"
+         #:unpack-path "golang.org/x/crypto"
+         #:phases
+         (modify-phases %standard-phases
+           (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
+             (lambda* (#:key outputs #:allow-other-keys)
+               (map (lambda (file)
+                      (make-file-writable file))
+                    (find-files
+                      (string-append (assoc-ref outputs "out")
+                                     "/src/golang.org/x/crypto/ed25519/testdata")
+                      ".*\\.gz$"))
+               #t)))))
+      (synopsis "Salsa20 in Go")
+      (description "This packages provides a Go implementation of the Salsa20
+stream cipher.")
+      (home-page "https://go.googlesource.com/crypto/")
+      (license bsd-3))))
+
 (define-public go-golang-org-x-sys-unix
   (let ((commit "f3918c30c5c2cb527c0b071a27c35120a6c0719a")
         (revision "0"))