summary refs log tree commit diff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-03-05 22:56:40 +0000
committerChristopher Baines <mail@cbaines.net>2021-03-06 00:18:30 +0000
commita8448da0f4a090818104e64dd79f90b0e50d5e77 (patch)
tree494c58b4724f12cd9de0db9b0a7096de2b922c0f /gnu/packages/syndication.scm
parent4f4b749e75b38b8c08b4f67ef51c2c8740999e28 (diff)
parenta714af38d5d1046081524d859cde4cd8fd12a923 (diff)
downloadguix-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 881660780c..f34a59ac17 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -24,6 +24,7 @@
   #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module (guix build-system cargo)
+  #:use-module (guix build-system qt)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
@@ -39,12 +40,14 @@
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages python-web)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages ruby)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tls)
@@ -357,3 +360,58 @@ a simple interface that makes it easy to organize and browse feeds.")
 \"river of news\" or a public \"planet\" page.  It supports all common feed
 formats, including all versions of RSS and Atom.")
     (license license:gpl2+)))
+
+(define-public quiterss
+  (package
+    (name "quiterss")
+    (version "0.19.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/QuiteRSS/quiterss")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1cgvl67vhn5y7bj5gbjbgk26bhb0196bgrgsp3r5fmrislarj8s6"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  (substitute* (find-files "." "\\.cpp$")
+                    ;; Disable Google Analytics spyware by default,
+                    ;; removing completely is not trivial.
+                    (("settings\\.value\\(\"Settings/statisticsEnabled2\", true\\)")
+                     "settings.value(\"Settings/statisticsEnabled2\", false)")
+                    ;; Disable update check spyware by default, otherwise runs
+                    ;; at every startup, nasty. Not needed on GNU Guix as a
+                    ;; feature either way.
+                    (("settings\\.value\\(\"Settings/updateCheckEnabled\", true\\)")
+                     "settings.value(\"Settings/updateCheckEnabled\", false)"))
+                  #t))))
+    (build-system qt-build-system)
+    (arguments
+     `(#:tests? #f ;; no test suite
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (invoke "qmake" "CONFIG+=release"
+                     (string-append "PREFIX="
+                                    (assoc-ref outputs "out"))
+                     (string-append "QMAKE_LRELEASE="
+                                    (assoc-ref inputs "qttools")
+                                    "/bin/lrelease")))))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("qttools" ,qttools)))
+    (inputs
+     `(("qtwebkit" ,qtwebkit)
+       ("qtbase" ,qtbase)
+       ("qtmultimedia" ,qtmultimedia)
+       ("phonon" ,phonon)
+       ("sqlite" ,sqlite)))
+    (home-page "https://quiterss.org/")
+    (synopsis "RSS/Atom news feeds reader written on Qt/C++")
+    (description "QuiteRSS is an RSS/Atom news feeds reader written on Qt/C++
+that aims to be quite fast and comfortable to it's user.")
+    (license license:gpl3+)))