summary refs log tree commit diff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-03-18 15:28:47 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-18 16:03:34 +0100
commita6de0c4c9c3f6642fbf653b1c202a39f53da40e5 (patch)
tree0d1d9664d98cf89775f971cc4c195f94bae08857 /gnu/packages/syndication.scm
parent7f9616717ffc75eba7b9278f3f31f10d17529fd3 (diff)
downloadguix-a6de0c4c9c3f6642fbf653b1c202a39f53da40e5.tar.gz
gnu: feh, newsboat: Inline top-level reference to 'curl'.
These references introduced top-level circular dependencies.
Furthermore, they were inaccurate since only CURL_CA_BUNDLE is honored.

* gnu/packages/image-viewers.scm (feh)[native-search-paths]: Remove
top-level reference to 'curl'; inline "CURL_CA_BUNDLE" spec.
* gnu/packages/syndication.scm (newsboat)[native-search-paths]:
Likewise.
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index cd35b665dc..0417737d7d 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -291,7 +291,11 @@ cards.")
            (assoc-ref gnu:%standard-phases 'install)))))
     (native-search-paths
      ;; Newsboat respects CURL_CA_BUNDLE.
-     (package-native-search-paths curl))
+     (list (search-path-specification
+            (variable "CURL_CA_BUNDLE")
+            (file-type 'regular)
+            (separator #f)                        ;single entry
+            (files '("etc/ssl/certs/ca-certificates.crt")))))
     (home-page "https://newsboat.org/")
     (synopsis "Text-mode RSS and Atom feed reader with podcast support")
     (description "Newsboat is a feed reader for @dfn{RSS} and @dfn{Atom}, XML