summary refs log tree commit diff
path: root/gnu/packages/synergy.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-26 15:14:53 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-26 15:14:53 +0200
commite1556533d3e57950417b2e35a68e95c65fee5042 (patch)
tree41d67b065c7828e164af83254fb447849d9e880d /gnu/packages/synergy.scm
parent5d8d8f3b0a07edb3bd435830b076749f906537d8 (diff)
parent92f1cefb74f6092c0c70f93140824ab806086272 (diff)
downloadguix-e1556533d3e57950417b2e35a68e95c65fee5042.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/synergy.scm')
-rw-r--r--gnu/packages/synergy.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/synergy.scm b/gnu/packages/synergy.scm
index 9a038bb545..905ef82af4 100644
--- a/gnu/packages/synergy.scm
+++ b/gnu/packages/synergy.scm
@@ -92,19 +92,15 @@
                      (ex  (string-append out "/share/doc/synergy-"
                                          ,version "/examples")))
                 (begin
-                  (mkdir-p bin)
                   (for-each
                    (lambda (f)
-                     (copy-file (string-append srcdir "/bin/" f)
-                                (string-append bin "/" f)))
+                     (install-file (string-append srcdir "/bin/" f) bin))
                    '("synergyc" "synergys" "synergyd"
                      "usynergy" "syntool"))
                   ;; Install example configuration files
-                  (mkdir-p ex)
                   (for-each
                    (lambda (e)
-                     (copy-file (string-append srcdir "/doc/" e)
-                                (string-append ex "/" e)))
+                     (install-file (string-append srcdir "/doc/" e) ex))
                    '("synergy.conf.example"
                      "synergy.conf.example-advanced"
                      "synergy.conf.example-basic")))))