summary refs log tree commit diff
path: root/gnu/packages/tbb.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-04-17 09:54:11 -0400
committerMark H Weaver <mhw@netris.org>2015-04-17 09:54:11 -0400
commit933204e5b1473a54367aef1f90de22424e9074ab (patch)
treed0ccfee2b903c5fac827bc4a52ec7de17bdc1e7b /gnu/packages/tbb.scm
parent9128e323c0a23243c3f70b1716c68ad0b241f30d (diff)
parent5e25ebe2fa70297d094fe891b81c4970e45a906a (diff)
downloadguix-933204e5b1473a54367aef1f90de22424e9074ab.tar.gz
Merge branch 'master' into core-updates
Conflicts:
	gnu-system.am
	gnu/packages/gstreamer.scm
Diffstat (limited to 'gnu/packages/tbb.scm')
-rw-r--r--gnu/packages/tbb.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/tbb.scm b/gnu/packages/tbb.scm
index 42670d77c0..3c41141dc6 100644
--- a/gnu/packages/tbb.scm
+++ b/gnu/packages/tbb.scm
@@ -46,8 +46,13 @@
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
-       #:phases (alist-delete
+       #:phases (alist-replace
                  'configure
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (substitute* "build/linux.gcc.inc"
+                     (("LIB_LINK_FLAGS =")
+                      (string-append "LIB_LINK_FLAGS = -Wl,-rpath="
+                                     (assoc-ref outputs "out") "/lib"))))
                  (alist-replace
                   'install
                   (lambda* (#:key outputs #:allow-other-keys)