summary refs log tree commit diff
path: root/gnu/packages/tbb.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-07-04 11:08:43 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-07-04 11:14:41 +0300
commitb56dad9b2cbd2396c6cbec4d9a9c9323d79906c6 (patch)
treee241889054da83bf4f8ff3756c443f17ec20f5f3 /gnu/packages/tbb.scm
parent47ed000d4df98e440a8a9a0788412b2f791b88b4 (diff)
downloadguix-b56dad9b2cbd2396c6cbec4d9a9c9323d79906c6.tar.gz
gnu: tbb: Fix building on riscv64-linux.
* gnu/packages/tbb.scm (tbb)[source]: Add patch.
* gnu/packages/patches/tbb-other-arches.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/tbb.scm')
-rw-r--r--gnu/packages/tbb.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/tbb.scm b/gnu/packages/tbb.scm
index e8fbc0f97e..d8c7d59c8d 100644
--- a/gnu/packages/tbb.scm
+++ b/gnu/packages/tbb.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2016 Nikita <nikita@n0.is>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -41,10 +42,11 @@
               (sha256
                (base32
                 "1z0pqzfx63zrmyqdvvkk8vl5dc0i0n5cimdkrypd50ig4d4yi7sc"))
-              (patches (list
-                        ;; Backport an upstream commit that prevents the
-                        ;; "test_eh_thread" test failing on AArch64.
-                        (search-patch "tbb-fix-test-on-aarch64.patch")))))
+              (patches
+                ;; Backport an upstream commit that prevents the
+                ;; "test_eh_thread" test failing on AArch64.
+                (search-patches "tbb-fix-test-on-aarch64.patch"
+                                "tbb-other-arches.patch"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags '("-DTBB_STRICT=OFF"))) ;; Don't fail on warnings