summary refs log tree commit diff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-07 11:56:13 -0500
committerMark H Weaver <mhw@netris.org>2015-01-07 12:05:16 -0500
commitc9a465555388867725cf455066ab909c9610c2f5 (patch)
tree8e41c160bba2022e77e9426b26e60fff158b2ea0 /gnu/packages/tcl.scm
parent3246cc91858a18344a6b62272521c88dd0ec5037 (diff)
downloadguix-c9a465555388867725cf455066ab909c9610c2f5.tar.gz
gnu: tcl: Pass --mandir to configure.
This partially reverts 9b1bf33081652210502c6ef34506e27a9bc60f06.
"gnu: Remove a bunch of now unneeded '--mandir' configure flags."

* gnu/packages/tcl.scm (tcl)[arguments]: Put back the --mandir configure flag,
  with a comment explaining why it's still needed.
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 2de2624df4..67510eb41f 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -63,6 +63,14 @@
                                       "tclsh")))))
                   %standard-phases))
 
+       ;; By default, man pages are put in PREFIX/man, but we want them in
+       ;; PREFIX/share/man.  The 'validate-documentation-location' phase is
+       ;; not able to fix this up because the default install populates both
+       ;; PREFIX/man and PREFIX/share/man.
+       #:configure-flags (list (string-append "--mandir="
+                                              (assoc-ref %outputs "out")
+                                              "/share/man"))
+
        ;; XXX: There are a few test failures (related to HTTP, most
        ;; likely related to name resolution), but that doesn't cause
        ;; `make' to fail.