summary refs log tree commit diff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-06-26 18:30:13 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:12:54 +0200
commitee4c8c899b91ff5a691213cb79ff181bc13fe76c (patch)
tree29fa5c8d4c2cc445b8dd9c93536b2adf1e72301c /gnu/packages/tcl.scm
parent2ce30a37ad5d74e368a8db4a1f38877ee9759a02 (diff)
downloadguix-ee4c8c899b91ff5a691213cb79ff181bc13fe76c.tar.gz
gnu: tk: Fix cross-compilation.
* gnu/packages/tcl.scm (tk)[arguments]: Add configure flags to fix
cross-compilation.
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 96f41e7928..9ef95b42ed 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -186,9 +186,16 @@ X11 GUIs.")
                                          "/lib -lfontconfig")))
                        #t))))
 
-       #:configure-flags (list (string-append "--with-tcl="
-                                              (assoc-ref %build-inputs "tcl")
-                                              "/lib"))
+       #:configure-flags
+       (list (string-append "--with-tcl="
+                            (assoc-ref %build-inputs "tcl")
+                            "/lib")
+             ;; This is needed when cross-compiling, see:
+             ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=719247
+             ,@(if (%current-target-system)
+                   '("tcl_cv_strtod_buggy=1"
+                     "ac_cv_func_strtod=yes")
+                   '()))
 
        ;; The tests require a running X server, so we just skip them.
        #:tests? #f))