summary refs log tree commit diff
path: root/gnu/packages/telegram.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2022-09-26 21:33:46 +0800
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-28 20:22:38 +0200
commitc59653b19e42f2ef2c1617fa0c08ac3db1e1df53 (patch)
treeb867232046c202d2033873d57c8064e2b3d7bb71 /gnu/packages/telegram.scm
parentb906aa6a7ce2dee15d64632805ca3d59305d9505 (diff)
downloadguix-c59653b19e42f2ef2c1617fa0c08ac3db1e1df53.tar.gz
gnu: telegram: Remove unused variables.
* gnu/packages/telegram.scm (lib-rlottie-for-telegram-desktop)
(lib-waylandshells-for-telegram-desktop,libtgvoip-for-telegram-desktop):
Remove variables.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/telegram.scm')
-rw-r--r--gnu/packages/telegram.scm65
1 files changed, 0 insertions, 65 deletions
diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 3461dc7bfb..2df68ccca7 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -168,18 +168,6 @@
      (base32
       "0hmwqj7a9vcy8wq7pd1qprl68im3zl5f1wzcn2zzk2wvi0389k9f"))))
 
-(define lib-rlottie-for-telegram-desktop
-  (origin
-    (method git-fetch)
-    (uri (git-reference
-          (url "https://github.com/desktop-app/lib_rlottie.git")
-          (commit "0671bf70547381effcf442ec9618e04502a8adbc")))
-    (file-name
-     (git-file-name "lib-rlottie-for-telegram-desktop" %telegram-version))
-    (sha256
-     (base32
-      "05qnza7j15356s8jq16pkbyp4zr586lssmd86lz5jq23lcb3raxv"))))
-
 (define lib-rpl-for-telegram-desktop
   (origin
     (method git-fetch)
@@ -240,18 +228,6 @@
      (base32
       "0kyrgxi202xwy14mnx62h1kny0434f5fxqns1ydp24q2c2cr1cxn"))))
 
-(define lib-waylandshells-for-telegram-desktop
-  (origin
-    (method git-fetch)
-    (uri (git-reference
-          (url "https://github.com/desktop-app/lib_waylandshells.git")
-          (commit "59b0ee55a68976d27f1bf7cec0e11d5939e185e7")))
-    (file-name
-     (git-file-name "lib-waylandshells-for-telegram-desktop" %telegram-version))
-    (sha256
-     (base32
-      "0l2xrpc5mvvdlsj333pmkgfvn9wi1ijfdaaz8skfnw9icw52faaf"))))
-
 (define lib-webrtc-for-telegram-desktop
   (origin
     (method git-fetch)
@@ -406,47 +382,6 @@ Telegram project, for its use in telegram desktop client.")
                (substitute* "meson.build"
                  (("werror=true") "werror=false"))))))))))
 
-(define-public libtgvoip-for-telegram-desktop
-  (let ((commit "13a5fcb16b04472d808ce122abd695dbf5d206cd")
-        (revision "88"))
-    (hidden-package
-     (package
-       (inherit libtgvoip)
-       (version
-        (git-version "2.4.4" revision commit))
-       (source
-        (origin
-          (method git-fetch)
-          (uri
-           (git-reference
-            (url "https://github.com/telegramdesktop/libtgvoip.git")
-            (commit commit)))
-          (file-name
-           (git-file-name "libtgvoip-for-telegram-desktop" version))
-          (sha256
-           (base32 "12p6s7vxkf1gh1spdckkdxrx7bjzw881ds9bky7l5fw751cwb3xd"))))
-       (arguments
-        `(#:configure-flags
-          (list
-           "--disable-static"
-           "--disable-dsp"              ; FIXME
-           "--enable-audio-callback"
-           "--with-alsa"
-           "--with-pulse")
-          #:phases
-          (modify-phases %standard-phases
-            (add-after 'unpack 'patch-linkers
-              (lambda _
-                (substitute* "Makefile.am"
-                  (("\\$\\(CRYPTO_LIBS\\) \\$\\(OPUS_LIBS\\)")
-                   "$(CRYPTO_LIBS) $(OPUS_LIBS) $(ALSA_LIBS) $(PULSE_LIBS)"))
-                (substitute* "tgvoip.pc.in"
-                  (("libcrypto opus")
-                   "libcrypto opus alsa libpulse"))
-                #t)))))
-       (native-inputs
-        (list autoconf automake libtool pkg-config))))))
-
 (define-public telegram-desktop
   (package
     (name "telegram-desktop")