summary refs log tree commit diff
path: root/gnu/packages/telephony.scm
diff options
context:
space:
mode:
authorJan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>2020-05-02 03:14:46 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-05-02 12:04:58 +0200
commit2ff4e549bbb8cb0e40f730830be0ba6d19269292 (patch)
tree68950fe406ebfb6f6b069e450db205ef449984e0 /gnu/packages/telephony.scm
parent7f8f39d344ed12983470b756696345778e5f1efc (diff)
downloadguix-2ff4e549bbb8cb0e40f730830be0ba6d19269292.tar.gz
gnu: pjproject-jami: Update to 2.10.
* gnu/packages/telephony.scm (pjproject): Update to 2.10,
[source]: reorder "file-name" and "sha256" fields.
* gnu/packages/jami.scm (%jami-version): Update to 20200401.1.6f090d,
(pjproject-jami)[arguments]: apply patches related to 2.10.

Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages/telephony.scm')
-rw-r--r--gnu/packages/telephony.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 747b0d75a1..17974e17f9 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -651,13 +651,17 @@ calls and messages")
 (define-public pjproject
   (package
     (name "pjproject")
-    (version "2.9")
+    (version "2.10")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/pjsip/pjproject.git")
-             (commit "5dfa75be7d69047387f9b0436dd9492bbbf03fe4")))
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1aklicpgwc88578k03i5d5cm5h8mfm7hmx8vfprchbmaa2p8f4z0"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -686,11 +690,7 @@ calls and messages")
               (lambda (dirs)
                 (substitute* "third_party/build/os-linux.mak"
                   (((string-append "DIRS += " dirs)) "")))
-              third-party-dirs))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "1ayj6n7zd5wvd1nzj2k9s57fb4ckc2fv92k5sjvhd87yg69k3393"))))
+              third-party-dirs))))))
     (build-system gnu-build-system)
     (inputs
      `(("portaudio" ,portaudio)))