summary refs log tree commit diff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-12-13 07:06:39 -0600
committerBrett Gilio <brettg@posteo.net>2019-12-13 07:06:39 -0600
commitd1efb11a0cfeb4cd18b8dca14683a6ebaf2c52ea (patch)
tree7b127f7ad7badd5f4bd1ea17899d445096213144 /gnu/packages/terminals.scm
parent5076c13b490bc798294119609688e8f2bf0e0cf5 (diff)
downloadguix-d1efb11a0cfeb4cd18b8dca14683a6ebaf2c52ea.tar.gz
gnu: python-blessings: Update comment on test suite.
* gnu/packages/terminals.scm (python-blessings): Test suite has been revised.
[arguments]: Change comment to reflect change in test suite regarding TTY.
[native-inputs]: Pass python-six, which is required for test suite.
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index e1f3307ba4..a385e62630 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -839,10 +839,11 @@ of VT100 terminal.")
          "0z8mgkbmisxs10rz88qg46l1c9a8n08k8cy2iassal2zh16qbrcq"))))
     (build-system python-build-system)
     (arguments
-     ;; TODO: For py3, 2to2 is used to convert the code, but test-suite fails
+     ;; FIXME: Test suite is unable to detect TTY conditions.
      `(#:tests? #f))
     (native-inputs
-     `(("python-nose" ,python-nose)))
+     `(("python-nose" ,python-nose)
+       ("python-six" ,python-six)))
     (home-page "https://github.com/erikrose/blessings")
     (synopsis "Python module to manage terminal color, styling, and
 positioning")