summary refs log tree commit diff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-09-23 12:52:17 +0200
committerDavid Craven <david@craven.ch>2016-09-28 12:40:12 +0200
commita3af70aca8166bd535e90d7b8afc930aa46fcbc2 (patch)
treeabf56b19623012bc6311772360465b6045b72e20 /gnu/packages/terminals.scm
parent615c999055a3e830b5bea61b541e0cce857dd6c8 (diff)
downloadguix-a3af70aca8166bd535e90d7b8afc930aa46fcbc2.tar.gz
gnu: Add picocom.
* gnu/packages/terminals.scm (picocom): New variable.
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index d5c24d2455..1f08bc88a7 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -259,3 +259,38 @@ multi-seat support, a replacement for @command{mingetty}, and more.")
                    license:gpl2+))
     (supported-systems (filter (cut string-suffix? "-linux" <>)
                                %supported-systems))))
+
+(define-public picocom
+  (package
+    (name "picocom")
+    (version "2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/npat-efault/picocom"
+                    "/archive/" version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1v891cx18vx3lnpfaq90f5y6njgigkn4qsikhrmyzshnz32jy5bb"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags '("CC=gcc")
+       #:tests? #f ; No tests
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin"))
+                    (man (string-append out "/share/man/man1")))
+               (install-file "picocom" bin)
+               (install-file "picocom.1" man)))))))
+    (home-page "https://github.com/npat-efault/picocom")
+    (synopsis "Minimal dumb-terminal emulation program")
+    (description "It was designed to serve as a simple, manual, modem
+configuration, testing, and debugging tool.  It has also serves well
+as a low-tech serial communications program to allow access to all
+types of devices that provide serial consoles.")
+    (license license:gpl2+)))