summary refs log tree commit diff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-23 23:39:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-23 23:40:30 +0200
commit075c9f12696d23bc86999b7a9ed567f38715e00a (patch)
tree9f1a3b5932ce8357f6ec19ae3b5006f31f1303b5 /gnu/packages/terminals.scm
parent82924c19530b386f1eb972fc84aa535365c3c012 (diff)
downloadguix-075c9f12696d23bc86999b7a9ed567f38715e00a.tar.gz
gnu: asciinema: Remove ncurses reference.
An external ‘tput’ is only required by ancient (<3.3) Pythons 3 and can
always be provided in $PATH.  It is not worth a reference.

* gnu/packages/terminals.scm (asciinema)[arguments]:
Remove 'patch-exec-paths phase.
[inputs]: Remove ncurses.
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm7
1 files changed, 0 insertions, 7 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index d606bf4bea..9fee37a04d 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -213,15 +213,8 @@ insert mode and command mode where keybindings have different functions.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-before 'build 'patch-exec-paths
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((ncurses (assoc-ref inputs "ncurses")))
-               (substitute* "asciinema/term.py"
-                 (("'tput'")
-                  (string-append "'" ncurses "/bin/tput'"))))))
          (replace 'check
            (lambda _ (invoke "nosetests" "-v"))))))
-    (inputs `(("ncurses" ,ncurses)))
     (native-inputs
      ;; For tests.
      `(("python-nose" ,python-nose)))