summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:05:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:34 +0200
commit4ed76e8fb4b767fdac11f3f734cd94256e5dc657 (patch)
treea0506118d6010fc403190fac8a8239e11a589322 /gnu/packages/tex.scm
parent6acd5a924abd3b289f513e703b2c8bcbfa1bcae8 (diff)
downloadguix-4ed76e8fb4b767fdac11f3f734cd94256e5dc657.tar.gz
gnu: Add texlive-xcpdftips.
* gnu/packages/tex.scm (texlive-xcpdftips): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 00458d44e8..560ece827f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -100130,6 +100130,26 @@ steps and required ingredients.  At the bottom you may insert an optional
 hint.  The package depends on the Emerald fonts.")
     (license license:lppl1.3+)))
 
+(define-public texlive-xcpdftips
+  (package
+    (name "texlive-xcpdftips")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/xcpdftips/"
+                   "source/latex/xcpdftips/"
+                   "tex/latex/xcpdftips/")
+             (base32
+              "16in0hkr8ij36xxclq6z0rxmkldn0pba49sj3vnfamrgq80r70xg")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/xcpdftips")
+    (synopsis "@code{natbib} citations with PDF tooltips")
+    (description
+     "This LaTeX package uses @code{pdfcomment} and @code{bibentry} to surround
+@code{natbib} citations with PDF tooltips.")
+    (license license:gpl3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar