summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-21 22:45:35 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:34 +0200
commitfaa3d5423683b73c59abf7b18646cc47ea9ba18b (patch)
treeb602b3205a997d913f987d4349e4400f5486c811 /gnu/packages/tex.scm
parent30c8c8a0a56e6291af95d13df9113115c95fe646 (diff)
downloadguix-faa3d5423683b73c59abf7b18646cc47ea9ba18b.tar.gz
gnu: Do not create origins for "ctxdocstrip.tex".
* gnu/packages/tex.scm (texlive-xecjk)[native-inputs]:
(texlive-xcjk2uni)[native-inputs]:
(texlive-xpinyin)[native-inputs]: Remove <origin> pointing to
"ctxdocstrip.tex".  Grab it from TEXLIVE-CTEX's source instead.

Change-Id: I8208f4e1cc25b6ac03e0727a41d79d0c76568bdc
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 3 insertions, 31 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 870d9b053a..9fd3735cf4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -39996,16 +39996,7 @@ undergraduate and postgraduate that meet the school's requirements.")
                             "build/")
               (setenv "TEXINPUTS" (string-append (getcwd) "/build:")))))))
     (native-inputs
-     (list (origin
-             (method svn-multi-fetch)
-             (uri (svn-multi-reference
-                   (url (texlive-packages-repository version))
-                   (revision 66594)
-                   (locations (list "tex/generic/ctex/ctxdocstrip.tex"))))
-             (file-name (git-file-name name version))
-             (sha256
-              (base32
-               "154v2d6wfzhfg654nlh2apy9zr78d09rkimymyjqpxymkpbk8lli")))))
+     (list (package-source texlive-ctex)))
     (home-page "https://ctan.org/pkg/xecjk")
     (synopsis "Support for CJK documents in XeLaTeX")
     (description
@@ -58589,17 +58580,7 @@ for the user.")
                             "build/")
               (setenv "TEXINPUTS" (string-append (getcwd) "/build:")))))))
     (native-inputs
-     (list texlive-ttfutils
-           (origin
-             (method svn-multi-fetch)
-             (uri (svn-multi-reference
-                   (url (texlive-packages-repository version))
-                   (revision 66594)
-                   (locations (list "tex/generic/ctex/ctxdocstrip.tex"))))
-             (file-name (git-file-name name version))
-             (sha256
-              (base32
-               "154v2d6wfzhfg654nlh2apy9zr78d09rkimymyjqpxymkpbk8lli")))))
+     (list (package-source texlive-ctex) texlive-ttfutils))
     (home-page "https://ctan.org/pkg/xcjk2uni")
     (synopsis "Convert CJK characters to Unicode, in pdfTeX")
     (description
@@ -58918,16 +58899,7 @@ others.")
       ;; should be a native input) and `ctex' (where this package is
       ;; a propagated input).  To work around this, grab the required
       ;; "ctxdocstrip.tex" file from `ctex'.
-      (origin
-        (method svn-multi-fetch)
-        (uri (svn-multi-reference
-              (url (texlive-packages-repository version))
-              (revision 66594)
-              (locations (list "tex/generic/ctex/ctxdocstrip.tex"))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "154v2d6wfzhfg654nlh2apy9zr78d09rkimymyjqpxymkpbk8lli")))))
+      (package-source texlive-ctex)))
     (home-page "https://ctan.org/pkg/xpinyin")
     (synopsis "Automatically add pinyin to Chinese characters")
     (description