summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 14:26:28 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 14:26:28 +0100
commit390f9604110b2f478db73eb5ce8dd3770cb59ea5 (patch)
tree1549c32ee7076a16c52e2ecd86fea2d16794673a /gnu/packages/tex.scm
parent78859540f60307383f4e30a43dc8d021092b11a2 (diff)
downloadguix-390f9604110b2f478db73eb5ce8dd3770cb59ea5.tar.gz
gnu: Add texlive-ulem.
* gnu/packages/tex.scm (texlive-ulem): New variable.
(texlive-latex-ulem): Deprecate variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 8 insertions, 26 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f2509c1d34..cb43a791fc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7824,33 +7824,13 @@ is preferred in many parts of the world, as distinct from that which is used in
 @code{\\maketitle} of the article class, \"June 26, 2008\", the 'US format'.")
     (license license:lppl)))
 
-(define-public texlive-generic-ulem
+(define-public texlive-ulem
   (package
-    (name "texlive-generic-ulem")
-    (version (number->string %texlive-revision))
-    (source
-     (origin
-       (method svn-fetch)
-       (uri (svn-reference
-             (url (string-append "svn://www.tug.org/texlive/tags/"
-                                 %texlive-tag "/Master/texmf-dist/"
-                                 "/tex/generic/ulem"))
-             (revision %texlive-revision)))
-       (file-name (string-append name "-" version "-checkout"))
-       (sha256
-        (base32
-         "161ka7sckiakcr1fgydxpc580sr16vp4sp3avjl2v9jn1pd2pwp0"))))
-    (build-system trivial-build-system)
-    (arguments
-     `(#:modules ((guix build utils))
-       #:builder
-       (begin
-         (use-modules (guix build utils))
-         (let ((target (string-append (assoc-ref %outputs "out")
-                                      "/share/texmf-dist/tex/generic/ulem")))
-           (mkdir-p target)
-           (copy-recursively (assoc-ref %build-inputs "source") target)
-           #t))))
+    (inherit (simple-texlive-package
+              "texlive-ulem"
+              (list "doc/generic/ulem/" "tex/generic/ulem/")
+              (base32 "0wcfnw5h6lsg2ilvkkf7mns8jgcn0n5sh45iznfsb49pfb4mming")
+              #:trivial? #t))
     (home-page "https://www.ctan.org/pkg/ulem")
     (synopsis "Underline text in TeX")
     (description
@@ -7861,6 +7841,8 @@ from a typewriter.  The package also offers double and wavy underlining, and
 striking out (line through words) and crossing out (/// over words).")
     (license license:lppl1.3c+)))
 
+(define-deprecated-package texlive-latex-ulem texlive-ulem)
+
 (define-public texlive-latex-pgf
   (package
     (name "texlive-latex-pgf")