summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:54:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:33 +0200
commit210b753d8c47b439030fef8e5ab9fc1abe0e08ae (patch)
treed8bfa2e80a65a705cdbc3648f055debf7268fdaa /gnu/packages/tex.scm
parentf1ad95b0ad116e52d4762314c50f4129f7da0974 (diff)
downloadguix-210b753d8c47b439030fef8e5ab9fc1abe0e08ae.tar.gz
gnu: Add texlive-langcode.
* gnu/packages/tex.scm (texlive-langcode): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e8de5a9ae8..69c81eb828 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2968,6 +2968,29 @@ macros shown in Appendix D of the TeXbook: all the manipulations take place in
 what Knuth is pleased to call ``TeX's mouth''.")
     (license license:lppl)))
 
+(define-public texlive-langcode
+  (package
+    (name "texlive-langcode")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/langcode/"
+                   "source/generic/langcode/"
+                   "tex/generic/langcode/")
+             (base32
+              "0ygshcc0iszaldzc8ygz4bgvz05c3kv81v3m7i4q46l57x2kfx6x")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/langcode")
+    (synopsis "Simple language-dependent settings based on language codes")
+    (description
+     "The package provides a command @code{\\uselangcode@{<code>@}} to adjust
+language-dependent settings such as key words, typographical conventions and
+language codes (ISO 639-1).  The package provides a means of selecting macros
+according to the specified code, for preparing a document that is to be
+separately typeset in different languages.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-tex
   (package
     (name "texlive-tex")