summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:53:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:32 +0200
commit7792c8c0aa501b785565d3e1b2b84ee2dfb8fc4f (patch)
treefb998552aecd3f34f01f5e4778c7b934b8ca38d9 /gnu/packages/tex.scm
parent749e2bb6a980f67de616075cf7aef25047abbdc9 (diff)
downloadguix-7792c8c0aa501b785565d3e1b2b84ee2dfb8fc4f.tar.gz
gnu: Add texlive-insbox.
* gnu/packages/tex.scm (texlive-insbox): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3a6b18960e..d1f4ddac9d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2911,6 +2911,24 @@ typesetting.")
 before it's read by TeX.")
     (license license:lppl1.3+)))
 
+(define-public texlive-insbox
+  (package
+    (name "texlive-insbox")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/insbox/" "tex/generic/insbox/")
+             (base32
+              "0br6xpn9y11nw2pdjxck6mijbw2q6g2v31p64hwn65bwnx1fnc25")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/insbox")
+    (synopsis "Insert pictures/boxes into paragraphs")
+    (description
+     "The package provides convenient bundling of the @code{\\parshape}
+primitive.  This is a TeX package.")
+    (license license:public-domain)))
+
 (define-public texlive-tex
   (package
     (name "texlive-tex")