summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 15:10:02 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-19 15:10:02 +0200
commit707babdde428bfd67d4ea9438d2f834946b1959e (patch)
tree7420b69bdaced762d6caf282ab25d1b945fc18b2 /gnu/packages/tex.scm
parentb718793e2a3e09f458d93f1a000846308a7eb878 (diff)
downloadguix-707babdde428bfd67d4ea9438d2f834946b1959e.tar.gz
gnu: Add texlive-latex-needspace.
* gnu/packages/tex.scm (texlive-latex-needspace): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9026c25596..064ec94243 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4522,3 +4522,28 @@ It also ensures compatibility with the @code{media9} and @code{animate} packages
 @item @command{ragged2e}, typeset ragged text and allow hyphenation.
 @end itemize\n")
     (license license:lppl1.3c+)))
+
+(define-public texlive-latex-needspace
+  (package
+    (name "texlive-latex-needspace")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (texlive-ref "latex" "needspace"))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "0kw80f5jh4gdpa2ka815abza3gr5z8b929w0745vrlc59pl0017y"))))
+    (build-system texlive-build-system)
+    (arguments
+     '(#:tex-directory "latex/needspace"
+       #:tex-format "latex"))
+    (inputs
+     `(("texlive-latex-filecontents" ,texlive-latex-filecontents)))
+    (home-page "https://www.ctan.org/pkg/needspace")
+    (synopsis "Insert pagebreak if not enough space")
+    (description
+     "Provides commands to disable pagebreaking within a given vertical
+space.  If there is not enough space between the command and the bottom of the
+page, a new page will be started.")
+    (license license:lppl)))