summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 22:17:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:42 +0200
commit7406c16b635647ca10a884032ade960075cbc48f (patch)
treec12a0dcbbb717d7863d91b8e9deeac0ff866ea94 /gnu/packages/tex.scm
parenteab3b8036951c5cf89d8be61373746af14b3eff0 (diff)
downloadguix-7406c16b635647ca10a884032ade960075cbc48f.tar.gz
gnu: texlive-paralist: Fix build.
* gnu/packages/tex.scm (texlive-paralist): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[arguments]: Remove unnecessary #:TEX-DIRECTORY keyword.
[native-inputs]: Remove unnecessary inputs.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm33
1 files changed, 15 insertions, 18 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1bd09121ca..498cef9898 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6485,26 +6485,23 @@ written especially for XeLaTeX users.")
 
 (define-public texlive-paralist
   (package
-    (inherit (simple-texlive-package
-              "texlive-paralist"
-              (list "doc/latex/paralist/README"
-                    "source/latex/paralist/paralist.dtx"
-                    "source/latex/paralist/paralist.ins")
-              (base32 "1lz8yds2i64wkb89a9amydwkzsdbc09s1kbgn7vgh2qsxqrrgwam")))
+    (name "texlive-paralist")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/paralist/" "source/latex/paralist/"
+                   "tex/latex/paralist/")
+             (base32
+              "003gs7rjm97vqh903wdjys3ls96kx45w3s4qghjk1fdjx6qxd32l")))
     (outputs '("out" "doc"))
-    (arguments
-     (list
-      #:tex-directory "latex/paralist"))
-    (native-inputs (list texlive-latex-base
-                         (texlive-updmap.cfg
-                          (list texlive-cm
-                                texlive-jknapltx))))
+    (build-system texlive-build-system)
     (home-page "https://ctan.org/pkg/paralist")
-    (synopsis "Enumerate and itemize within paragraphs")
-    (description "The @code{paralist} package provides enumerate and itemize
-environments that can be used within paragraphs to format the items either as
-running text or as separate paragraphs with a preceding number or symbol.  It
-also provides compacted versions of enumerate and itemize.")
+    (synopsis "@code{enumerate} and @code{itemize} within paragraphs")
+    (description "The @code{paralist} package provides @code{enumerate} and
+@code{itemize} environments that can be used within paragraphs to format the
+items either as running text or as separate paragraphs with a preceding number
+or symbol.  It also provides compacted versions of @code{enumerate} and
+@code{itemize}.")
     (license license:lppl1.0+)))
 
 (define-public texlive-polyglossia