summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 23:58:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:18 +0200
commit743373c12568073c53406e57676868c7ae8ba500 (patch)
tree2687f0552cf14a17bc16a63d40fc887fd2055ff0 /gnu/packages/tex.scm
parent2fe780d14dc79122e0d45aa1fe578794e38ad73c (diff)
downloadguix-743373c12568073c53406e57676868c7ae8ba500.tar.gz
gnu: texlive-mflogo-font: Refresh package definition.
* gnu/packages/tex.scm (texlive-mflogo-font): Remove SIMPLE-TEXLIVE-PACKAGE
call.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7f8822c0cf..91f28574d5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1676,17 +1676,20 @@ logos in LaTeX documents.")
 
 (define-public texlive-mflogo-font
   (package
-    (inherit (simple-texlive-package
-              "texlive-mflogo-font"
-              (list "/doc/fonts/mflogo-font/README"
-                    "/fonts/afm/hoekwater/mflogo-font/"
-                    "/fonts/map/dvips/mflogo-font/"
-                    "/fonts/type1/hoekwater/mflogo-font/")
-              (base32
-               "094mknjv8ki2pvj1zin0f1z4f1w12g0cfqjiqcsawjsry4yfrmbg")
-              #:trivial? #t))
-    (home-page "https://www.ctan.org/pkg/mflogo-font")
-    (synopsis "Metafont logo font")
+    (name "texlive-mflogo-font")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/mflogo-font/"
+                   "fonts/afm/hoekwater/mflogo-font/"
+                   "fonts/map/dvips/mflogo-font/"
+                   "fonts/type1/hoekwater/mflogo-font/")
+             (base32
+              "094mknjv8ki2pvj1zin0f1z4f1w12g0cfqjiqcsawjsry4yfrmbg")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/mflogo-font")
+    (synopsis "METAFONT logo font")
     (description
      "These fonts were created in METAFONT by Knuth, for his own publications.
 At some stage, the letters P and S were added, so that the METAPOST logo could