summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-05-02 11:49:18 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-02 11:49:18 +0200
commit92831e206cef5abccc473f7a0d0584374f89d343 (patch)
tree2d98bb46c8a13893cdfc000b63c4e2fd6aaaf0d2 /gnu/packages/tex.scm
parent3f8c4899a9a67bb509a603bd21dcfcfab88c0e8e (diff)
downloadguix-92831e206cef5abccc473f7a0d0584374f89d343.tar.gz
gnu: Add texlive-alphalph.
* gnu/packages/tex.scm (texlive-alphalph): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a2f1de4e35..930bb134ea 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -668,6 +668,26 @@ executables.  It is maintained as a part of TeX Live.")))
     (deprecated-package (symbol->string 'old-name) name)))
 
 
+(define-public texlive-alphalph
+  (package
+    (inherit (simple-texlive-package
+              "texlive-alphalph"
+              (list "doc/latex/alphalph/"
+                    "source/latex/alphalph/"
+                    "tex/generic/alphalph/")
+              (base32
+               "0ap59hmg0brg2wlh3bl77jxfxrk7hphhdal8cr05mby9bw35gffy")
+              #:trivial? #t))
+    (home-page "https://ctan.org/pkg/alphalph")
+    (synopsis "Convert numbers to letters")
+    (description
+     "This package provides commands @code{\\alphalph} and @code{\\AlphAlph}.
+They are like @code{\\number} but the expansion consists of lowercase and
+uppercase letters respectively (1 to a, 26 to z, 27 to aa, 52 to zz, 53 to ba,
+702 to zz, 703 to aaa, etc.).  Can be used as a replacement for LaTeX's
+@code{\\@@alph} and @code{\\@@Alph} macros.")
+    (license license:lppl1.3+)))
+
 (define texlive-docstrip
   (package
     (inherit (simple-texlive-package