summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:08:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:14 +0200
commit0d70c6a3abdb88f28164bb33fabc05d281603609 (patch)
tree3ae1b7d778fca8b3b7761b361cfc8ccc45677190 /gnu/packages/tex.scm
parent4455e2352ab0d747c1eaae93de10b1c2d4600e62 (diff)
downloadguix-0d70c6a3abdb88f28164bb33fabc05d281603609.tar.gz
gnu: Add texlive-calculation.
* gnu/packages/tex.scm (texlive-calculation): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d2010b6577..c2b4bf671e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2060,6 +2060,32 @@ a packet or in memory.")
 in Python, C and Pascal.  Program source files may also be input.")
     (license license:public-domain)))
 
+(define-public texlive-calculation
+  (package
+    (name "texlive-calculation")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/calculation/"
+                   "source/latex/calculation/"
+                   "tex/latex/calculation/")
+             (base32
+              "15sk3v1cwpjln4rp9k877awxaz9js5gbazlzjknmv5fv1cb4d09c")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/calculation")
+    (synopsis
+     "Typesetting reasoned calculations, also called calculational proofs")
+    (description
+     "The @code{calculation} environment formats reasoned calculations, also
+called calculational proofs.  The package allows steps and expressions to be
+numbered (by LaTeX equation numbers, obeying the LaTeX @code{\\label} command
+to refer to these numbers), and a step doesn't take vertical space if its hint
+is empty.  An expression in a calculation can be given a comment; it is placed
+at the side opposite to the equation numbers.  Calculations are allowed inside
+hints although numbering and commenting is then disabled.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-catcodes
   (package
     (name "texlive-catcodes")