summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:06:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 17:12:56 +0200
commitdf92eb7c643ab1de123a1d5b10bd3498f5c6e64b (patch)
tree442280ef1279742e627805318af9b61cf087c030 /gnu/packages/tex.scm
parentf2e1a9cfcdb7786fd8015a04c4d515252e944fd1 (diff)
downloadguix-df92eb7c643ab1de123a1d5b10bd3498f5c6e64b.tar.gz
gnu: Add texlive-bodeplot.
* gnu/packages/tex.scm (texlive-bodeplot): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b6b3e39032..47e5a83dc2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1835,6 +1835,39 @@ retains outer braces.")
 used to describe hardware, data format or protocols.")
     (license license:lppl)))
 
+(define-public texlive-bodeplot
+  (package
+    (name "texlive-bodeplot")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/bodeplot/"
+                   "source/latex/bodeplot/"
+                   "tex/latex/bodeplot/")
+             (base32
+              "1wlzfdm7ngassxhlcq2yc94id6szijan334l5png7avmifkz7m5y")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/bodeplot")
+    (synopsis "Draw Bode, Nyquist and Nichols plots with Gnuplot or
+ @code{pgfplots}")
+    (description
+     "This is a LaTeX package to plot Bode, Nichols, and Nyquist diagrams.  It
+provides added functionality over the similar @code{bodegraph} package:
+
+@itemize
+@item new @code{\\BodeZPK} and @code{\\BodeTF} commands to generate Bode plots
+of any transfer function given either poles, zeros, gain, and delay, or
+numerator and denominator coefficients and delay;
+@item support for unstable poles and zeros;
+@item support for complex poles and zeros;
+@item support for general stable and unstable second order transfer functions;
+@item support for both Gnuplot (default) and @code{pgfplots};
+@item support for linear and asymptotic approximation of magnitude and phase
+plots of any transfer function given poles, zeros, and gain.
+@end itemize")
+    (license license:lppl1.3c)))
+
 (define-public texlive-borceux
   (package
     (name "texlive-borceux")