summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-31 13:38:55 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:22 -0400
commit0c50d0bda1507701b2d09b34f55b1af9872a7bf6 (patch)
treeae60d4993ee0467699b9de50cef38e6e81368b6d /gnu/packages/tex.scm
parent8ed911cb25ff1a76e9c395bf7d7f1f98ef060543 (diff)
downloadguix-0c50d0bda1507701b2d09b34f55b1af9872a7bf6.tar.gz
gnu: Add texlive-ncctools.
* gnu/packages/tex.scm (texlive-ncctools): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e755b8d715..1190a3fd97 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9235,6 +9235,70 @@ typeset the table of contents in multiple columns.")
 
 (define-deprecated-package texlive-latex-ms texlive-ms)
 
+(define-public texlive-ncctools
+  (let ((template (simple-texlive-package
+                   "texlive-ncctools"
+                   (list "doc/latex/ncctools/"
+                         "source/latex/ncctools/"
+                         "tex/latex/ncctools/")
+                   (base32
+                    "1g3fpvrg6kx2ns97ih6iwdk0rcbxlv043x8rdppxdincl2lvbdx5"))))
+    (package
+      (inherit template)
+      (outputs '("out" "doc"))
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ #t) "latex/ncctools")
+         ((#:build-targets _ '()) '(list "ncctools.ins"))
+         ((#:phases phases)
+          #~(modify-phases #$phases
+              (add-after 'unpack 'chdir
+                (lambda _ (chdir "source/latex/ncctools/")))
+              (replace 'copy-files
+                (lambda* (#:key inputs #:allow-other-keys)
+                  (let ((origin (assoc-ref inputs "source"))
+                        (source (string-append #$output
+                                               "/share/texmf-dist/source"))
+                        (doc (string-append #$output:doc
+                                            "/share/texmf-dist/doc")))
+                    (copy-recursively (string-append origin "/source") source)
+                    (copy-recursively (string-append origin "/doc") doc))))))))
+      (propagated-inputs
+       (list texlive-amsmath texlive-latex-graphics))
+      (home-page "https://ctan.org/pkg/ncctools")
+      (synopsis "Collection of general packages for LaTeX")
+      (description
+       "The NCCtools bundle contains many packages for general use under LaTeX;
+many are also used by NCC LaTeX.  The bundle includes tools for:
+@itemize
+@item executing commands after a package is loaded;
+@item watermarks;
+@item counter manipulation;
+@item improvements to the @code{description} environment;
+@item hyphenation of compound words;
+@item new levels of footnotes;
+@item space-filling patterns;
+@item poor man's Black Board Bold symbols;
+@item alignment of the content of a box; use comma as decimal separator;
+@item boxes with their own crop marks;
+@item page cropmarks;
+@item improvements to fancy headers;
+@item float styles, mini floats, side floats;
+@item manually marked footnotes;
+@item extension of amsmath;
+@item control of paragraph skip;
+@item an envelope to the @code{graphicx} package;
+@item dashed and multiple rules;
+@item alternative techniques for declarations of sections, captions, and
+toc-entries;
+@item generalised text-stretching;
+@item generation of new theorem-like environments;
+@item control of the text area;
+@item centered page layouts;
+@item un-numbered top-level section.
+@end itemize")
+      (license license:lppl))))
+
 (define-public texlive-numprint
   (let ((template
          (simple-texlive-package