summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-03 13:42:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-03 15:36:13 +0200
commit04cbef14ff6ac2e1c89214ceafcb21103f40031f (patch)
treed9e4033cea846b42be4c1f9284561fbf93744334 /gnu/packages/tex.scm
parent5874f8a051ba6696412b826a4313f27d9d5407cc (diff)
downloadguix-04cbef14ff6ac2e1c89214ceafcb21103f40031f.tar.gz
gnu: Add texlive-pagenote.
* gnu/packages/tex.scm (texlive-pagenote): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2c039b731a..54b503e465 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8141,6 +8141,33 @@ floats merely delays the arrival of the inevitable error message.")
 testing whether an argument is empty.")
       (license license:lppl1.3c+))))
 
+(define-public texlive-pagenote
+  (let ((template (simple-texlive-package
+                   "texlive-pagenote"
+                   (list "/doc/latex/pagenote/"
+                         "/source/latex/pagenote/")
+                   (base32
+                    "0cqfqrfvnzq7ldaf255hcvi8xsfx8h7iha3hs8p9gdi3cfzbcmjm"))))
+    (package
+      (inherit template)
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ '())
+          "latex/pagenote")
+         ((#:build-targets _ '())
+          ''("pagenote.ins"))
+         ((#:phases phases)
+          `(modify-phases ,phases
+             (add-after 'unpack 'chdir
+               (lambda _ (chdir "source/latex/pagenote")))))))
+      (propagated-inputs
+       `(("texlive-ifmtarg" ,texlive-ifmtarg)))
+      (home-page "https://www.ctan.org/pkg/pagenote")
+      (synopsis "Notes at end of document")
+      (description "The pagenote package provides tagged notes on a separate
+page (also known as ‘end notes’).")
+      (license license:lppl1.3c+))))
+
 (define-public texlive-kastrup
   (package
     (name "texlive-kastrup")