summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2021-07-08 19:13:19 -0300
committerLudovic Courtès <ludo@gnu.org>2021-07-24 16:23:24 +0200
commit7bef3be1d318beebaf48ac6daa3140205ba18e98 (patch)
tree717f179a70ef2cc7c2dae4b6686ede4d8aa2af5c /gnu/packages/tex.scm
parent1feca4be5296d7f0c0e2269ccb612cadded6573b (diff)
downloadguix-7bef3be1d318beebaf48ac6daa3140205ba18e98.tar.gz
gnu: texlive-bin: Use ‘--with-banner-add’ configure option
The “Building TeX Live” manual has a section about configure options for
distro builds¹. They mention this option:

    --with-banner-add=/SomeDistro

    This isn’t technically required, but is strongly recommended, so your
    build and your distro can be distinguished from others.

Therefore add it to texlive-bin. This is how it appears on LuaTeX, for
example (it also shows up in other engines’ banners):

    $ luatex
    This is LuaTeX, Version 1.13.0 (TeX Live 2021/GNU Guix)
    restricted system commands enabled.
    **

The other options mentioned in that section are already being used.

¹ http://www.tug.org/texlive/doc/tlbuild.html#Distro-builds

* gnu/packages/tex.scm (texlive-bin)[arguments]: Add ‘--with-banner-add’
option.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 33d9064c80..bf918ff8d2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -321,6 +321,7 @@ files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
        '("--disable-static"
          "--disable-native-texlive-build"
          "--enable-shared"
+         "--with-banner-add=/GNU Guix"
          "--with-system-cairo"
          "--with-system-freetype2"
          "--with-system-gd"