summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-12 23:24:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-13 09:37:52 +0100
commit00e560fa0fcee2aaacd9c7ffeb1d37179dacafaa (patch)
tree7ebcd5540ab6e2242075450e773a656130ac9cb1 /gnu/packages/tex.scm
parent9749fb2c3f2eb6e816d68bb9ed8ad29fea46ef2d (diff)
downloadguix-00e560fa0fcee2aaacd9c7ffeb1d37179dacafaa.tar.gz
gnu: Add texlive-amsmath.
This is a corrected variant of texlive-latex-amsmath, which should be removed.

* gnu/packages/tex.scm (texlive-amsmath): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5d5e875a51..c1ec591096 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4035,6 +4035,51 @@ mathematics, and @code{ntheoremntheorem}, for specifying theorem (and similar)
 definitions.")
     (license license:lppl1.3c+)))
 
+(define-public texlive-amsmath
+  (let ((template (simple-texlive-package
+                   "texlive-amsmath"
+                   (list "/doc/latex/amsmath/"
+                         "/source/latex/amsmath/"
+                         ;; These two files are not generated from any of the
+                         ;; dtx/ins files.
+                         "/tex/latex/amsmath/amsmath-2018-12-01.sty"
+                         "/tex/latex/amsmath/amstex.sty")
+                   (base32
+                    "0gmdzhgr0h57xhsl61c5jsp4fj4pbmdr8p6k96am5jbyrbbx121q"))))
+    (package
+      (inherit template)
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ #t)
+          "latex/amsmath")
+         ((#:phases phases)
+          `(modify-phases ,phases
+             (add-after 'unpack 'chdir
+               (lambda _ (chdir "source/latex/amsmath/")))
+             (add-before 'copy-files 'unchdir
+               (lambda _
+                 (chdir "../../..")))
+             (add-after 'copy-files 'delete-extra-files
+               (lambda* (#:key outputs #:allow-other-keys)
+                 (delete-file-recursively
+                  (string-append (assoc-ref outputs "out")
+                                 "/share/texmf-dist/source/latex/amsmath/build"))))))))
+      (home-page "https://www.ctan.org/pkg/amsmath")
+      (synopsis "AMS mathematical facilities for LaTeX")
+      (description
+       "This is the principal package in the AMS-LaTeX distribution.  It adapts
+for use in LaTeX most of the mathematical features found in AMS-TeX; it is
+highly recommended as an adjunct to serious mathematical typesetting in LaTeX.
+When amsmath is loaded, AMS-LaTeX packages @code{amsbsyamsbsy} (for bold
+symbols), @code{amsopnamsopn} (for operator names) and
+@code{amstextamstext} (for text embedded in mathematics) are also loaded.
+This package is part of the LaTeX required distribution; however, several
+contributed packages add still further to its appeal; examples are
+@code{empheqempheq}, which provides functions for decorating and highlighting
+mathematics, and @code{ntheoremntheorem}, for specifying theorem (and similar)
+definitions.")
+      (license license:lppl1.3c+))))
+
 (define-public texlive-amscls
   (let ((template (simple-texlive-package
                    "texlive-amscls"