summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2021-08-19 21:47:15 -0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-22 14:17:05 +0300
commitbf53a26a3a32c2ac9f7bbf7e663aa6fff04421ab (patch)
tree17508e7cacc9c095fca6b8e2c36c816188ae9d9d /gnu/packages/tex.scm
parent06e258c3c08cdd78bf329e4c8a5543749f13d8d2 (diff)
downloadguix-bf53a26a3a32c2ac9f7bbf7e663aa6fff04421ab.tar.gz
gnu: texlive-texmf: Disable LuaJIT engines on powerpc64le.
LuaJIT isn’t ported to 64-bit PowerPC. ‘texlive-bin’ and
‘texlive-latex-base’ already disable the engines that rely on it, so just
do the same in texlive-texmf.

Fix suggested by Mathieu Othacehe <othacehe@gnu.org>.

* gnu/packages/tex.scm (texlive-texmf)[arguments]: Disable LuaJIT
engines when building for powerpc64le.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4500f19292..43901a375e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6829,9 +6829,15 @@ directly generate PDF documents instead of DVI.")
                      (share (string-append out "/share"))
                      (texmfroot (string-append share "/texmf-dist/web2c"))
                      (texmfcnf (string-append texmfroot "/texmf.cnf"))
+                     (fmtutilcnf (string-append texmfroot "/fmtutil.cnf"))
                      (texlive-bin (assoc-ref inputs "texlive-bin"))
                      (texbin (string-append texlive-bin "/bin"))
                      (tlpkg (string-append texlive-bin "/share/tlpkg")))
+                ;; LuaJIT is not ported to powerpc64* yet.
+                (if ,(target-ppc64le?)
+                    (substitute* fmtutilcnf
+                      (("^(luajittex|luajithbtex|mfluajit)" m)
+                       (string-append "#! " m))))
                 ;; Register SHARE as TEXMFROOT in texmf.cnf.
                 (substitute* texmfcnf
                   (("TEXMFROOT = \\$SELFAUTOPARENT")