summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:30:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:52 +0200
commite31843cdbf8295aeb3a0d1376231781b3e2abb09 (patch)
tree3c7849f2f7c4c4ddcd037e810509291aa0ed0f43 /gnu/packages/tex.scm
parenta34c51d73b848d18ba2284fe185d0ff5f65c4c6a (diff)
downloadguix-e31843cdbf8295aeb3a0d1376231781b3e2abb09.tar.gz
gnu: Add texlive-texware.
* gnu/packages/tex.scm (texlive-texware): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0eeb46297f..a48d463b40 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6625,6 +6625,31 @@ application is powerful enough to generate any text-based structure, given
 that a corresponding template exists.")
     (license license:bsd-3)))
 
+(define-public texlive-texware
+  (package
+    (name "texlive-texware")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/dvitype.1"
+                   "doc/man/man1/dvitype.man1.pdf"
+                   "doc/man/man1/pooltype.1"
+                   "doc/man/man1/pooltype.man1.pdf")
+             (base32
+              "122r0aq02vwx6irsnapnfbvhgy5d09x90rc8zc7a0bi7b25bxnd1")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/texware")
+    (synopsis "Utility programs for use with TeX")
+    (description
+     "This package provides basic utility programs, comprising:
+@command{dvitype}, which converts a TeX output (DVI) file to a plain text
+file; @command{pooltype}, which converts a TeX-suite program's pool (string)
+file into human-readable form; @command{tftopl} and @command{pltotf}, which
+convert TeX Font Metric (TFM) file to human readable Property List (PL) files
+and vice versa.")
+    (license license:public-domain)))
+
 (define-public texlive-ticollege
   (package
     (name "texlive-ticollege")