summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:42:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:56 +0200
commitf1e1ce32c2ac6ce419fe81ed1c49f7d738a7a6ce (patch)
tree0b6080cc87918d03c69f84a0f122e7470e6a95f5 /gnu/packages/tex.scm
parent3fbe61197c50c64f7afcc15d3eb547510a1477fa (diff)
downloadguix-f1e1ce32c2ac6ce419fe81ed1c49f7d738a7a6ce.tar.gz
gnu: Add texlive-dviasm.
* gnu/packages/tex.scm (texlive-dviasm): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index df86e9f931..8121e1c4f8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1702,6 +1702,30 @@ LaTeX source (.dtx) file.")
 the document.")
     (license license:gpl2)))
 
+(define-public texlive-dviasm
+  (package
+    (name "texlive-dviasm")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/dviasm/" "doc/man/man1/dviasm.1"
+                   "doc/man/man1/dviasm.man1.pdf"
+                   "scripts/dviasm/")
+             (base32
+              "1hx4j0pmh4h3194xxcvjnh5nr069sysbqxvg4zzmci6gjr7mjg7f")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:link-scripts #~(list "dviasm.py")))
+    (inputs (list python))
+    (home-page "https://ctan.org/pkg/dviasm")
+    (synopsis "Utility for editing DVI files")
+    (description
+     "This package provides a Python script to support changing or creating
+DVI files via disassembling into text, editing, and then reassembling into
+binary format.  It supports advanced features such as adding a preprint number
+or watermarks.")
+    (license license:gpl3+)))
+
 (define-public texlive-dvipsconfig
   (package
     (name "texlive-dvipsconfig")