summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-10 22:37:26 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:13 +0200
commit876a198058dcb380b8e5c118e2529cb402730fb5 (patch)
tree386fccad2c21735c315fff8dab06f42abc34c620 /gnu/packages/tex.scm
parentfedd77c102b6e8fe814f6ab930567e240b5def3f (diff)
downloadguix-876a198058dcb380b8e5c118e2529cb402730fb5.tar.gz
gnu: Add texlive-generic-babel-english.
* gnu/packages/tex.scm (texlive-generic-babel-english): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6fad118258..27fb594da9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1464,6 +1464,28 @@ what has to be done for each language.  Users of XeTeX are advised to use the
 polyglossia package rather than Babel.")
     (license license:lppl1.3+)))
 
+(define-public texlive-generic-babel-english
+  (package
+    (name "texlive-generic-babel-english")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (texlive-ref "generic" "babel-english"))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "1s404wbx91z5w65hm024kyl4h56zsa096irx18vsx8jvlmwsr5wc"))))
+    (build-system texlive-build-system)
+    (arguments '(#:tex-directory "generic/babel-english"))
+    (home-page "http://www.ctan.org/pkg/babel-english")
+    (synopsis "Babel support for English")
+    (description
+     "This package provides the language definition file for support of
+English in @code{babel}.  Care is taken to select British hyphenation patterns
+for British English and Australian text, and default (\"american\") patterns
+for Canadian and USA text.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-latex-cyrillic
   (package
     (name "texlive-latex-cyrillic")