summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-05 22:24:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-05 22:45:42 +0200
commit66d213350019f94c95e8a3f7efb7dfb2de8894ef (patch)
tree1ef6952a1766b868c45ba76fd024fc0e5dff1217 /gnu/packages/tex.scm
parent69f0c8cf5566848f0065f84d73c7d76e01475842 (diff)
downloadguix-66d213350019f94c95e8a3f7efb7dfb2de8894ef.tar.gz
gnu: Add texlive-booktabs.
* gnu/packages/tex.scm (texlive-booktabs): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2b15ffb0cd..43e1c44c72 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7337,3 +7337,25 @@ The package also provides backward-compatibility with @code{SIunits},
 @code{sistyle}, @code{unitsdef} and @code{units}.  The aim is to have one
 package to handle all of the possible unit-related needs of LaTeX users.")
     (license license:lppl1.3c)))
+
+(define-public texlive-booktabs
+  (package
+    (name "texlive-booktabs")
+    (version (number->string %texlive-revision))
+    (source
+     (origin
+       (method svn-fetch)
+       (uri (texlive-ref "latex" "booktabs"))
+       (sha256
+        (base32
+         "1dqid48vgh25wmw8xzmx6x3pfgz1y9f0r8aza1yxq2mjny5yf68x"))))
+    (build-system texlive-build-system)
+    (arguments '(#:tex-directory "latex/booktabs"))
+    (home-page "http://www.ctan.org/pkg/booktabs")
+    (synopsis "Publication quality tables in LaTeX")
+    (description
+     "This package enhances the quality of tables in LaTeX, providing extra
+commands as well as behind-the-scenes optimisation.  Guidelines are given as
+to what constitutes a good table in this context.  The package offers
+@code{longtable} compatibility.")
+    (license license:lppl1.3+)))