summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-03-02 15:48:15 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-02 19:26:15 +0100
commitca6de276db0de1a4b7fdd29dbfea401937f50ff7 (patch)
tree9bc04c322fbd4aad92807b88724f048a06ff8b89 /gnu/packages/tex.scm
parentee6275c9744f8649bccc8cfa7c52d100044d7570 (diff)
downloadguix-ca6de276db0de1a4b7fdd29dbfea401937f50ff7.tar.gz
gnu: texlive-bin: Skip faulty tests on armhf-linux.
Fixes <https://issues.guix.gnu.org/54055>.
Reported by Christopher Baines <mail@cbaines.net>.

* gnu/packages/tex.scm (texlive-bin)[arguments]: When 'target-arm32?' is
true, add 'skip-faulty-test' phase.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 531f866b58..90f3500f11 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -436,6 +436,18 @@ files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
            (lambda _
              (substitute* "texk/kpathsea/config.h"
                (("#define ST_NLINK_TRICK") ""))))
+
+         ,@(if (target-arm32?)
+               `((add-after 'unpack 'skip-faulty-test
+                   (lambda _
+                     ;; Skip this faulty test on armhf-linux:
+                     ;;   https://issues.guix.gnu.org/54055
+                     (substitute* '("texk/mendexk/tests/mendex.test"
+                                    "texk/upmendex/tests/upmendex.test")
+                       (("^TEXMFCNF=" all)
+                        (string-append "exit 77 # skip\n" all))))))
+               '())
+
          (add-after 'check 'customize-texmf.cnf
            ;; The default texmf.cnf is provided by this package, texlive-bin.
            ;; Every variable of interest is set relatively to the GUIX_TEXMF