summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-11 09:49:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-11 09:56:30 +0300
commite192b9e02d7cf6f063b6fe0895a0d3f7b34cc9b7 (patch)
tree6d02f25f0de0280048157108053a72bb47bf4cec /gnu/packages/tex.scm
parentdadf97952d574e6e44d10a2eb0e2afef86a96818 (diff)
downloadguix-e192b9e02d7cf6f063b6fe0895a0d3f7b34cc9b7.tar.gz
gnu: lyx: Use qt-build-system.
* gnu/packages/tex.scm (lyx)[build-system]: Switch to qt-build-system.
[arguments]: Remove imported modules. Remove custom 'wrap-qt phase.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f7d5fd1506..47645a3e34 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33,9 +33,9 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system perl)
+  #:use-module (guix build-system qt)
   #:use-module (guix build-system trivial)
   #:use-module (guix build-system texlive)
   #:use-module (guix utils)
@@ -6130,7 +6130,7 @@ and Karl Berry.")
                '(begin
                   (delete-file-recursively "3rdparty")
                   #t))))
-    (build-system cmake-build-system)
+    (build-system qt-build-system)
     (arguments
      `(#:configure-flags `("-DLYX_USE_QT=QT5"
                            "-DLYX_EXTERNAL_BOOST=1"
@@ -6139,11 +6139,6 @@ and Karl Berry.")
                            "-DLYX_PROGRAM_SUFFIX=OFF"
                            ,(string-append "-DLYX_INSTALL_PREFIX="
                                            (assoc-ref %outputs "out")))
-       #:modules ((guix build cmake-build-system)
-                  (guix build qt-utils)
-                  (guix build utils))
-       #:imported-modules (,@%cmake-build-system-modules
-                            (guix build qt-utils))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-python
@@ -6163,10 +6158,6 @@ and Karl Berry.")
              ;; Create missing file that would cause tests to fail.
              (with-output-to-file "src/tests/check_layout.cmake"
                (const #t))
-             #t))
-         (add-after 'install 'wrap-qt
-           (lambda* (#:key outputs #:allow-other-keys)
-             (wrap-qt-program (assoc-ref outputs "out") "lyx")
              #t)))))
     (inputs
      `(("boost" ,boost)