summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-04-04 19:49:22 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-04-04 20:19:19 +0200
commit5a46779e9f418b89137b315ba15d5c5ea30ca540 (patch)
tree56014ed2033cc31cee4d15d3627cb68e58b19c95 /gnu/packages/tex.scm
parent525e83ec83eca8d555913e59235902fa635b052d (diff)
downloadguix-5a46779e9f418b89137b315ba15d5c5ea30ca540.tar.gz
gnu: rubber: Make some inputs native.
* gnu/packages/tex.scm (rubber)[inputs]: Move texinfo from here...
[native-inputs]: ...to this new field.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e4346d1232..cd461314b5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12,6 +12,7 @@
 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Danny Milosavljevic <dannym+a@scratchpost.org>
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6132,8 +6133,8 @@ other things it comes with full Unicode support.")
                "1xbkv8ll889933gyi2a5hj7hhh216k04gn8fwz5lfv5iz8s34gbq"))))
     (build-system gnu-build-system)
     (arguments '(#:tests? #f))                    ; no `check' target
-    (inputs `(("texinfo" ,texinfo)
-              ("python" ,python-2) ; incompatible with Python 3 (print syntax)
+    (native-inputs `(("texinfo" ,texinfo)))
+    (inputs `(("python" ,python-2) ; incompatible with Python 3 (print syntax)
               ("which" ,which)))
     (home-page "https://launchpad.net/rubber")
     (synopsis "Wrapper for LaTeX and friends")