summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-04-11 10:34:23 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-04-21 00:19:33 +0530
commitb02b6f32a56a259873e8368ac0be2aed9eca76aa (patch)
tree0c81afc4e7164a6851c2ddab3c18abc5e26c6490 /gnu/packages/tex.scm
parenta9fda571c3e702ccd6b40f7ee320e55fd2e83d19 (diff)
downloadguix-b02b6f32a56a259873e8368ac0be2aed9eca76aa.tar.gz
gnu: texlive-bin: Patch texlua shebangs.
* gnu/packages/tex.scm (texlive-bin)[arguments]: Patch texlua shebangs in
postint phase.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2b35250dd0..35b6b3f8d4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -206,7 +206,13 @@
                (with-directory-excursion "texlive-extra"
                  (apply unpack (list #:source texlive-extra))
                  (apply patch-source-shebangs (list #:source texlive-extra))
-                 (invoke "mv" "tlpkg" share))))))))
+                 (invoke "mv" "tlpkg" share))
+               ;; texlua shebangs are not patched by the patch-source-shebangs
+               ;; phase because the texlua executable does not exist at that
+               ;; time.
+               (setenv "PATH" (string-append (getenv "PATH") ":" out "/bin"))
+               (with-directory-excursion out
+                 (patch-source-shebangs))))))))
    (synopsis "TeX Live, a package of the TeX typesetting system")
    (description
     "TeX Live provides a comprehensive TeX document production system.