summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 14:24:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 14:27:28 -0400
commit3c6e220d8100281074c414a43c1efe9a01b53771 (patch)
treedc5d47fbbac3842d0da893adcd398dea10c1e681 /gnu/packages/tex.scm
parent08473753a0ebafef22c0894d846e3b42fd6be2a2 (diff)
parent62048ff9fcfbe3fc790a7207fc5f6f3e0476a02a (diff)
downloadguix-3c6e220d8100281074c414a43c1efe9a01b53771.tar.gz
Merge branch 'master' into staging.
With resolved conflicts in:
	gnu/local.mk
	gnu/packages/crates-io.scm
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm84
1 files changed, 84 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 92342c0121..1fa3178a24 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6209,6 +6209,45 @@ the same place.  The package also has a range of techniques for labelling
 footnotes with symbols rather than numbers.")
     (license license:lppl1.3+)))
 
+(define-public texlive-latex-frankenstein
+  (package
+    (name "texlive-latex-frankenstein")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (svn-reference (url (string-append
+                                        "svn://www.tug.org/texlive/tags/"
+                                        %texlive-tag "/Master/texmf-dist/"
+                                        "/tex/latex/frankenstein"))
+                                  (revision %texlive-revision)))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "1zhdvn3zgdarlzfcyq8nzilvw0v0bqgl4m0y7j233cbqw8wiil4z"))))
+    (build-system trivial-build-system)
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder (begin
+                   (use-modules (guix build utils))
+                   (let ((target (string-append (assoc-ref %outputs "out")
+                                  "/share/texmf-dist/tex/latex/frankenstein")))
+                     (mkdir-p target)
+                     (copy-recursively (assoc-ref %build-inputs "source")
+                                       target) #t))))
+    (home-page "https://ctan.org/pkg/frankenstein")
+    (synopsis "Collection of unrelated LaTeX packages")
+    (description
+     "Frankenstein is a bundle of LaTeX packages serving various purposes and a
+BibTeX bibliography style.  The individual packages are: @code{abbrevs},
+@code{achicago}, @code{achicago} bibstyle, @code{attrib}, @code{blkcntrl},
+@code{compsci}, @code{dialogue}, @code{lips}, @code{moredefs}, @code{newclude},
+@code{slemph} and @code{titles}.  Note: The installation follows the suboptimal
+``Quick and dirty'' recipe, rendering some features unavailable.")
+    ;; README mentions an unspecified version of GNU GPL and points to COPYING,
+    ;; which is missing. However, the individual files mention LPPL 1.2 or
+    ;; later.
+    (license license:lppl1.2+)))
+
 (define-public texlive-latex-letltxmacro
   (package
     (inherit (simple-texlive-package
@@ -6929,6 +6968,24 @@ They combine a comprehensive Unicode-based collection of mathematical symbols
 and alphabets with a set of text faces suitable for professional publishing.")
       (license license:silofl1.1))))
 
+(define-public texlive-latex-sidecap
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-sidecap"
+              (list "doc/latex/sidecap/"
+                    "tex/latex/sidecap/")
+              (base32 "1biyxvh7fm70pq1rxqrla2vs013bpsd1j8jvlyl3vjg433d5bly3")
+              #:trivial? #t))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/sidecap")
+    (synopsis "Typeset captions sideways")
+    (description
+     "@code{sidecap} defines environments called @code{SCfigure} and
+@code{SCtable} (analogous to @code{figure} and @code{table}) to typeset
+captions sideways.  Options include @code{outercaption}, @code{innercaption},
+@code{leftcaption} and @code{rightcaption}.")
+    (license license:lppl1.0+)))
+
 (define-public texlive-stmaryrd
   (let ((template (simple-texlive-package
                    "texlive-stmaryrd"
@@ -11238,6 +11295,33 @@ Danish in @code{babel}.  It provides all the necessary macros, definitions and
 settings to typeset Danish documents.")
       (license license:lppl1.3c+))))
 
+(define-public texlive-babel-polish
+  (let ((template (simple-texlive-package
+                   "texlive-babel-polish"
+                   (list "/source/generic/babel-polish/")
+                   (base32
+                    "1jymxl98mwxmq0yq90mhrr7bq7c613rh1rnhl7l3bih36af55rwr"))))
+    (package
+      (inherit template)
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ '())
+          "generic/babel-polish")
+         ((#:build-targets _ '())
+          ''("polish.ins")) ; TODO: use dtx and build documentation
+         ((#:phases phases)
+          `(modify-phases ,phases
+             (add-after 'unpack 'chdir
+               (lambda _
+                 (chdir "source/generic/babel-polish")))))))
+      (home-page "https://www.ctan.org/pkg/babel-polish")
+      (synopsis "Babel support for Polish")
+      (description
+       "This package provides the language definition file for support of
+Polish in @code{babel}.  Some shortcuts are defined, as well as translations to
+Polish of standard ``LaTeX names''.")
+      (license license:lppl1.3+))))
+
 (define-public texlive-mdframed
   (package
     (inherit