summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-01 01:29:22 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-14 09:24:50 -0500
commit2c12d73a6236c56ae48c8b9df49ba36a49f76396 (patch)
tree686269b677a2afe7c750adfc07dbcd29216e658f /gnu/packages/tex.scm
parent2596099c257b0be5ad5cb24e98aaa1d73c3d7a55 (diff)
downloadguix-2c12d73a6236c56ae48c8b9df49ba36a49f76396.tar.gz
gnu: Add texlive-marvosym.
* gnu/packages/tex.scm (texlive-marvosym): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3c5f08196e..b51b4672ea 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14,6 +14,7 @@
 ;;; Copyright © 2018, 2020 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5504,6 +5505,32 @@ CM-Super family of fonts.  The package also offers its own LaTeX support for
 OT2 encoded fonts, CM bright shaped fonts and Concrete shaped fonts.")
     (license license:lppl)))
 
+(define-public texlive-marvosym
+  (package
+    (inherit (simple-texlive-package
+              "texlive-marvosym"
+              (list "/doc/fonts/marvosym/"
+                    "/fonts/afm/public/marvosym/"
+                    "/fonts/map/dvips/marvosym/"
+                    "/fonts/tfm/public/marvosym/"
+                    "/fonts/truetype/public/marvosym/"
+                    "/fonts/type1/public/marvosym/"
+                    "/tex/latex/marvosym/")
+              (base32
+               "0m3bbg06cia8ni86fjhvb7x4a5qcxgnpqcvicfms91w2px9ysc46")
+              #:trivial? #t))
+    (home-page "https://martinvogel.de/blog/index.php?\
+/archives/131-Marvosym.ttf.html")
+    (synopsis "Martin Vogel's Symbols (marvosym) font")
+    (description "The Martin Vogel’s Symbols fonts (marvosym) contains the
+Euro currency symbol as defined by the European commission, along with symbols
+for structural engineering, symbols for steel cross-sections, astronomy
+signs (sun, moon, planets), the 12 signs of the zodiac, scissor symbols, CE
+sign and others.  This package contains both the original TrueType font and
+the derived Type 1 font, together with support files for TeX (LaTeX).")
+    (license (list license:lppl          ;for TeX support files
+                   license:silofl1.1)))) ;for fonts
+
 (define-public texlive-metapost
   (package
     (name "texlive-metapost")