summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-03 13:42:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-03 15:36:13 +0200
commita202baf8e914583d98ab61f62eac595148cd0fb7 (patch)
treeaf17dac57b872a93665e1db04d875a467abc12dc /gnu/packages/tex.scm
parent962be3af65569d113941d64e0413bd347cd93dd5 (diff)
downloadguix-a202baf8e914583d98ab61f62eac595148cd0fb7.tar.gz
gnu: Add texlive-morefloats.
* gnu/packages/tex.scm (texlive-morefloats): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bd22e065ab..6ad910f1c6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8083,6 +8083,36 @@ all of LaTeX's sectional headers in the article, book, or report classes.
 Examples include the addition of rules above or below a section title. ")
       (license license:lppl1.2+))))
 
+(define-public texlive-morefloats
+  (let ((template (simple-texlive-package
+                   "texlive-morefloats"
+                   (list "/doc/latex/morefloats/"
+                         "/source/latex/morefloats/")
+                   (base32
+                    "0n0405fjxyjlbjspzfvhl0wjkwiqicj3hk8fa0g7agw72wlxscpl"))))
+    (package
+      (inherit template)
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ '())
+          "latex/morefloats")
+         ((#:build-targets _ '())
+          ''("morefloats.ins"))
+         ((#:phases phases)
+          `(modify-phases ,phases
+             (add-after 'unpack 'chdir
+               (lambda _ (chdir "source/latex/morefloats")))))))
+      (home-page "https://www.ctan.org/pkg/morefloats")
+      (synopsis "Increase the number of simultaneous LaTeX floats")
+      (description "LaTeX can, by default, only cope with 18 outstanding floats;
+any more, and you get the error “too many unprocessed floats”.  This package
+releases the limit; TeX itself imposes limits (which are independent of the
+help offered by e-TeX).
+
+However, if your floats can’t be placed anywhere, extending the number of
+floats merely delays the arrival of the inevitable error message.")
+      (license license:lppl1.3c+))))
+
 (define-public texlive-kastrup
   (package
     (name "texlive-kastrup")