summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-09 12:30:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-15 17:03:18 +0200
commit18e366e856645a8095974d2fa738e13af66f1ad4 (patch)
tree9bfc45ffdde7cf72668949a2c052a5a30b966cba /gnu/packages/tex.scm
parent2573163a127950b976adf83d8b10d3c8ded9ed76 (diff)
downloadguix-18e366e856645a8095974d2fa738e13af66f1ad4.tar.gz
gnu: Add texlive-latex-amscls.
* gnu/packages/tex.scm (texlive-latex-amscls): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8fb5c8b56f..da86650299 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1251,6 +1251,29 @@ mathematics, and @code{ntheoremntheorem}, for specifying theorem (and similar)
 definitions.")
     (license license:lppl1.3c+)))
 
+(define-public texlive-latex-amscls
+  (package
+    (name "texlive-latex-amscls")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (texlive-ref "latex" "amscls"))
+              (sha256
+               (base32
+                "0jmcr37mcdi7drczppvr6lmz5d5yd9m67ii79gp2nglg1xpw934j"))))
+    (build-system texlive-build-system)
+    (arguments
+     `(#:tex-directory "latex/amscls"))
+    (home-page "http://www.ctan.org/pkg/amscls")
+    (synopsis "AMS document classes for LaTeX")
+    (description
+     "This bundle contains three AMS classes: @code{amsartamsart} (for writing
+articles for the AMS), @code{amsbookamsbook} (for books) and
+@code{amsprocamsproc} (for proceedings), together with some supporting
+material.  The material is made available as part of the AMS-LaTeX
+distribution.")
+    (license license:lppl1.3c+)))
+
 (define texlive-texmf
   (package
    (name "texlive-texmf")