summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-12 03:40:24 -0400
committerMark H Weaver <mhw@netris.org>2018-04-12 04:02:52 -0400
commit286eedeca00fd66c786e3c2995a9d517c4226a46 (patch)
tree33f6932175097bb459475b187d927c478c8ccb9f /gnu/packages/tex.scm
parentd582d925e5467b0df808656b6ba7391376d9d114 (diff)
downloadguix-286eedeca00fd66c786e3c2995a9d517c4226a46.tar.gz
gnu: texlive-texmf: Use invoke instead of system*.
* gnu/packages/tex.scm (texlive-texmf)[arguments]: Use invoke instead of
system*, and return #t from all phases.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 64d21da6e9..9aa2f2ee4c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3936,7 +3936,7 @@ directly generate PDF documents instead of DVI.")
             (lambda* (#:key outputs #:allow-other-keys)
               (let ((share (string-append (assoc-ref outputs "out") "/share")))
                 (mkdir-p share)
-                (system* "mv" "texmf-dist" share))))
+                (invoke "mv" "texmf-dist" share))))
           (add-after 'install 'texmf-config
             (lambda* (#:key inputs outputs #:allow-other-keys)
               (let* ((out (assoc-ref outputs "out"))
@@ -3964,9 +3964,10 @@ directly generate PDF documents instead of DVI.")
                 ;; http://slackbuilds.org/repository/13.37/office/texlive/
                 (setenv "PATH" (string-append (getenv "PATH") ":" texbin))
                 (setenv "TEXMFCNF" texmfroot)
-                (system* "updmap-sys" "--nohash" "--syncwithtrees")
-                (system* "mktexlsr")
-                (system* "fmtutil-sys" "--all")))))))
+                (invoke "updmap-sys" "--nohash" "--syncwithtrees")
+                (invoke "mktexlsr")
+                (invoke "fmtutil-sys" "--all")
+                #t))))))
    (properties `((max-silent-time . 9600))) ; don't time out while grafting
    (synopsis "TeX Live, a package of the TeX typesetting system")
    (description