summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorTom Fitzhenry <tom@tom-fitzhenry.me.uk>2022-06-24 21:08:35 +1000
committerLudovic Courtès <ludo@gnu.org>2022-08-08 17:26:18 +0200
commit6ba74ab29c641c9b43b64473a69e3210c132eeca (patch)
tree3febc46a2140623b47e9be242f12efea02139128 /gnu/packages/tex.scm
parentbb907402a613494e7fb6f8f04bf8d9d16ff9ee66 (diff)
downloadguix-6ba74ab29c641c9b43b64473a69e3210c132eeca.tar.gz
gnu: Remove texlive's dependence on ruby-rspec and ruby-byebug.
Motivation: Break the dependency chain from guix to mariadb.

Prior to this patch:

$ guix graph --path guix mariadb
guix@1.3.0-27.598f728
po4a@0.63
texlive-tiny@59745
texlive-latex-base@59745
texlive-hyphen-afrikaans@59745
ruby-hydra@0.0-0.5abfa37
ruby-byebug@11.1.3
ruby-rubocop@1.10.0
ruby-parallel@1.21.0
ruby-mysql2@0.5.2
mariadb@10.5.12

As of this patch:

$ ./pre-inst-env guix graph --path guix mariadb
guix graph: error: no path from 'guix@1.3.0-27.598f728' to 'mariadb@10.5.12'

* gnu/local.mk (dist_patch_DATA): Add texlive-hyph-utf8-no-byebug.patch.
* gnu/packages/patches/texlive-hyph-utf8-no-byebug.patch: New file.
* gnu/packages/tex.scm (hyph-utf8-scripts): Add patch.
(texlive-hyphen-package): Depend on ruby-hydra-minimal.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ddcd0043c4..d075a6e475 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -157,6 +157,7 @@ copied to their outputs; otherwise the TEXLIVE-BUILD-SYSTEM is used."
     (file-name (string-append "hyph-utf8-scripts-"
                               (number->string %texlive-revision)
                               "-checkout"))
+    (patches (search-patches "texlive-hyph-utf8-no-byebug.patch"))
     (sha256
      (base32
       "04xzf5gr3ylyh3ls09imrx4mwq3qp1k97r9njzlan6hlff875rx2"))))
@@ -225,7 +226,7 @@ files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
                      (invoke "ruby" "generate-ptex-patterns.rb")))))))))
       (native-inputs
        `(("ruby" ,ruby)
-         ("ruby-hydra" ,ruby-hydra)
+         ("ruby-hydra-minimal" ,ruby-hydra-minimal)
          ("hyph-utf8-scripts" ,hyph-utf8-scripts)))
       (home-page "https://ctan.org/pkg/hyph-utf8"))))