summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-10 18:02:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-11 09:56:15 +0300
commit7a7a29445ced24af0dcdabfe8011538711fe05d9 (patch)
tree2c70e9109555a9ad2206a534d05c97a40b11f91e /gnu/packages/tex.scm
parent8971f626f2e69987bea729307adb93a0be243234 (diff)
downloadguix-7a7a29445ced24af0dcdabfe8011538711fe05d9.tar.gz
gnu: lyx: Wrap binary.
 Fixes <https://bugs.gnu.org/37147>.

* gnu/packages/tex.scm (lyx)[arguments]: Import qt-utils. Add phase to
wrap the lyx2.3 binary.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6f6ea73ffc..16c80324fd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2016, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
 ;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
@@ -6140,6 +6140,11 @@ and Karl Berry.")
                                            (assoc-ref %outputs "out")
                                            ;; Exact name and level is necessary.
                                            "/lyx" ,(version-major+minor version)))
+       #:modules ((guix build cmake-build-system)
+                  (guix build qt-utils)
+                  (guix build utils))
+       #:imported-modules (,@%cmake-build-system-modules
+                            (guix build qt-utils))
        #:phases
        (modify-phases %standard-phases
          ;; See ;; https://www.lyx.org/trac/changeset/3a123b90af838b08680471d87170c38e56787df9/lyxgit
@@ -6177,6 +6182,14 @@ and Karl Berry.")
                                         ,(version-major+minor version) #\-)) "x")
                      (string-append (getcwd) "/../lyx-" ,version "/lib"))
              #t))
+         (add-after 'install 'wrap-qt
+           (lambda* (#:key outputs #:allow-other-keys)
+             (wrap-qt-program (assoc-ref outputs "out")
+                              (string-append "../lyx"
+                                             ,(version-major+minor version)
+                                             "/bin/lyx"
+                                             ,(version-major+minor version)))
+             #t))
          (add-after 'install 'install-symlinks
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))