summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 00:19:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:59 +0200
commit5c0d75bf1e1039ebb61bd4533d24cc85ecf29886 (patch)
treea31b8030f3aabf6e4c1b443739540fb426ca1ab8 /gnu/packages/tex.scm
parent7b46032adf2ea40656643dee75f42eca720d260c (diff)
downloadguix-5c0d75bf1e1039ebb61bd4533d24cc85ecf29886.tar.gz
gnu: texlive-epstopdf-pkg: Refresh package definition.
* gnu/packages/tex.scm (texlive-epstopdf-pkg): Remove SIMPLE-TEXLIVE-PACKAGE
call.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm47
1 files changed, 22 insertions, 25 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 82f9c14423..0e705ea25c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3426,33 +3426,30 @@ the @file{.aux} file.")
 (define-deprecated-package texlive-latex-auxhook texlive-auxhook)
 
 (define-public texlive-epstopdf-pkg
-  (let ((template (simple-texlive-package
-                   "texlive-epstopdf-pkg"
-                   (list "doc/latex/epstopdf-pkg/"
-                         "source/latex/epstopdf-pkg/"
-                         "tex/latex/epstopdf-pkg/")
-                   (base32
-                    "1ajyc5pkn1niifz5asyf09vbdqvmy05xwl0vxcdl7ik0ll0jcaxp"))))
-    (package
-     (inherit template)
-     (arguments
-      (substitute-keyword-arguments (package-arguments template)
-        ((#:tex-directory _ '())
-         "latex/epstopdf-pkg")
-        ((#:build-targets _ '())
-         #~(list "epstopdf.ins"))))
-     (propagated-inputs
-      (list texlive-grfext
-            texlive-infwarerr
-            texlive-kvoptions
-            texlive-pdftexcmds))
-     (home-page "https://www.ctan.org/pkg/epstopdf-pkg")
-     (synopsis "Call @command{epstopdf} on the fly")
-     (description
-      "The package adds support for EPS files in the @code{graphicx} package
+  (package
+    (name "texlive-epstopdf-pkg")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/epstopdf-pkg/"
+                   "source/latex/epstopdf-pkg/"
+                   "tex/latex/epstopdf-pkg/")
+             (base32
+              "1ajyc5pkn1niifz5asyf09vbdqvmy05xwl0vxcdl7ik0ll0jcaxp")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-grfext
+           texlive-infwarerr
+           texlive-kvoptions
+           texlive-pdftexcmds))
+    (home-page "https://www.ctan.org/pkg/epstopdf-pkg")
+    (synopsis "Call @command{epstopdf} on the fly")
+    (description
+     "The package adds support for EPS files in the @code{graphicx} package
 when running under pdfTeX.  If an EPS graphic is detected, the package spawns
 a process to convert the EPS to PDF, using the script @command{epstopdf}.")
-     (license license:lppl1.3c+))))
+    (license license:lppl1.3c+)))
 
 (define-deprecated-package texlive-latex-epstopdf-pkg texlive-epstopdf-pkg)