summary refs log tree commit diff
path: root/gnu/packages/texinfo.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-06-05 10:31:43 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-06-05 10:31:43 +0200
commit6503b10bdc18d13d0aca76a9bf7cdb75a89e0adc (patch)
tree56d2a422f1385f15c458c05fae43da53f06fdf0b /gnu/packages/texinfo.scm
parent11ae7e9e45153b63c4bcd1625a6156da512d65a7 (diff)
downloadguix-6503b10bdc18d13d0aca76a9bf7cdb75a89e0adc.tar.gz
gnu: info-reader: Remove perl reference.
info-reader inherits from texinfo and uses substitute-keyword-arguments. If no
phases are defined in texinfo, then phases won't be modified in info-reader.

* gnu/packages/texinfo.scm (texinfo)[arguments]: Use %standard-phases when not
cross-compiling so that substitute-keyword-arguments behaves as expected in
inherited packages.
Diffstat (limited to 'gnu/packages/texinfo.scm')
-rw-r--r--gnu/packages/texinfo.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index 70e050371d..7dca37b51a 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
-;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;;
@@ -59,16 +59,16 @@
      ;; with the native compiler, the environment is reset. This leads to
      ;; multiple environment variables missing. Do not reset the environment
      ;; to prevent that.
-     (if (%current-target-system)
-         '(#:phases
-           (modify-phases %standard-phases
-             (add-before 'configure 'fix-cross-configure
-               (lambda _
-                 (substitute* "configure"
-                   (("env -i")
-                    "env "))
-                 #t))))
-         '()))
+     `(#:phases
+       (if ,(%current-target-system)
+            (modify-phases %standard-phases
+              (add-before 'configure 'fix-cross-configure
+                (lambda _
+                  (substitute* "configure"
+                    (("env -i")
+                     "env "))
+                  #t)))
+            %standard-phases)))
     (inputs `(("ncurses" ,ncurses)
               ;; TODO: remove `if' in the next rebuild cycle.
               ,@(if (%current-target-system)