summary refs log tree commit diff
path: root/gnu/packages/texinfo.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-17 15:01:52 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-17 15:03:06 +0100
commita24b75d8e1753da629ecf945f4022eee4c340aed (patch)
treef25ab165d2c5991bcc028ff55ff3b60d184334a1 /gnu/packages/texinfo.scm
parente49951eb3e1e1a8e7bad6d7471483e70b0865352 (diff)
downloadguix-a24b75d8e1753da629ecf945f4022eee4c340aed.tar.gz
gnu: texinfo: Update to 5.0.
* gnu/packages/texinfo.scm (texinfo): Update to 5.0.
Diffstat (limited to 'gnu/packages/texinfo.scm')
-rw-r--r--gnu/packages/texinfo.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index 9a264c627c..dba5cd2c2e 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,28 +22,26 @@
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages perl)
   #:use-module (gnu packages ncurses))
 
 (define-public texinfo
   (package
     (name "texinfo")
-    (version "4.13a")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append
-            "mirror://gnu/texinfo/texinfo-"
-            version
-            ".tar.lzma"))
-      (sha256
-       (base32
-        "1rf9ckpqwixj65bw469i634897xwlgkm5i9g2hv3avl6mv7b0a3d"))))
+    (version "5.0")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://gnu/texinfo/texinfo-"
+                                 version ".tar.xz"))
+             (sha256
+              (base32
+               "1p34f68h9ggfj6ckgj0p62qlj7pmz3ha3vc91kh4hr44pnwm1pla"))))
     (build-system gnu-build-system)
-    (inputs `(("ncurses" ,ncurses) ("xz" ,xz)))
-    (home-page
-     "http://www.gnu.org/software/texinfo/")
-    (synopsis
-     "GNU Texinfo, the GNU documentation system")
+    (inputs `(("perl" ,perl)                      ; yuck!
+              ("ncurses" ,ncurses)
+              ("xz" ,xz)))
+    (home-page "http://www.gnu.org/software/texinfo/")
+    (synopsis "GNU Texinfo, the GNU documentation system")
     (description
      "Texinfo is the official documentation format of the GNU project.
 It was invented by Richard Stallman and Bob Chassell many years