summary refs log tree commit diff
path: root/gnu/packages/texinfo.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-07-25 16:37:44 -0500
committerEric Bavier <bavier@member.fsf.org>2014-08-11 12:22:53 -0500
commitc5d837684359e3629c4ac96297a25d1165edcb39 (patch)
treed04319f6c260d38f2b32caa547429af2672ec89d /gnu/packages/texinfo.scm
parent3d6e65d529d93743ba3a5d6ddef0f28894fc4591 (diff)
downloadguix-c5d837684359e3629c4ac96297a25d1165edcb39.tar.gz
gnu: Add texi2html.
* gnu/packages/texinfo.scm (texi2html): New variable.
* gnu/packages/patches/texi2html-document-encoding.patch: New patch.
* gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/texinfo.scm')
-rw-r--r--gnu/packages/texinfo.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index 0f21ec3211..9388979a69 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,7 +22,9 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages ncurses))
 
@@ -64,3 +67,35 @@ is on expressing the content semantically, avoiding physical markup commands.")
                (base32
                 "1rf9ckpqwixj65bw469i634897xwlgkm5i9g2hv3avl6mv7b0a3d"))))
     (inputs `(("ncurses" ,ncurses) ("xz" ,xz)))))
+
+(define-public texi2html
+  (package
+    (name "texi2html")
+    (version "5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://savannah/" name "/" name "-"
+                                  version ".tar.bz2"))
+              (sha256
+               (base32
+                "1yprv64vrlcbksqv25asplnjg07mbq38lfclp1m5lj8cw878pag8"))
+              (patches (list (search-patch "texi2html-document-encoding.patch")))))
+    (build-system gnu-build-system)
+    (native-inputs `(("gettext" ,gnu-gettext)))
+    (inputs `(("perl" ,perl)))
+    (home-page "http://www.nongnu.org/texi2html/")
+    (synopsis "Convert Texinfo to HTML")
+    (description
+     "Texi2HTML is a Perl script which converts Texinfo source files to HTML
+output.  It now supports many advanced features, such as internationalization
+and extremely configurable output formats.
+
+Development of Texi2HTML moved to the GNU Texinfo repository in 2010, since it
+was meant to replace the makeinfo implementation in GNU Texinfo.  The route
+forward for authors is, in most cases, to alter manuals and build processes as
+necessary to use the new features of the makeinfo/texi2any implementation of
+GNU Texinfo.  The Texi2HTML maintainers (one of whom is the principal author
+of the GNU Texinfo implementation) do not intend to make further releases of
+Texi2HTML.")
+    ;; Files in /lib under lgpl2.1+ and x11
+    (license gpl2+)))