summary refs log tree commit diff
path: root/gnu/packages/texlive.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-10-29 14:40:12 +0100
committerAndreas Enge <andreas@enge.fr>2014-10-29 21:21:48 +0100
commitbe2c88caa0480391cbe1a72757b32ef9f119cc97 (patch)
treedc28aac54ea20ac32f90c5a6a7349329acba4edf /gnu/packages/texlive.scm
parent3b239720598a83f8bc88ff2026b743b45235cd08 (diff)
downloadguix-be2c88caa0480391cbe1a72757b32ef9f119cc97.tar.gz
gnu: texlive: Use system graphite2 instead of bundled copy.
* gnu/packages/texlive.scm (texlive): Add graphite2 as an input and modify
    the configure flags accordingly.
Diffstat (limited to 'gnu/packages/texlive.scm')
-rw-r--r--gnu/packages/texlive.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/texlive.scm b/gnu/packages/texlive.scm
index 86ec30fdac..b57630871e 100644
--- a/gnu/packages/texlive.scm
+++ b/gnu/packages/texlive.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -70,8 +70,9 @@
              ("fontconfig" ,fontconfig)
              ("freetype" ,freetype)
              ("gd" ,gd)
-             ("icu4c" ,icu4c)
              ("ghostscript" ,ghostscript)
+             ("graphite2" ,graphite2)
+             ("icu4c" ,icu4c)
              ("libpng" ,libpng)
              ("libxaw" ,libxaw)
              ("libxt" ,libxt)
@@ -102,7 +103,7 @@
          "--with-system-cairo"
          "--with-system-freetype2"
          "--with-system-gd"
-         ;; "--with-system-graphite2"  ; requires cmake build system
+         "--with-system-graphite2"
          ;; "--with-system-harfbuzz"   ; requires --with-system-graphite2
          "--with-system-icu"
          "--with-system-libgs"