summary refs log tree commit diff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-03-18 15:40:15 -0400
committerKei Kebreau <kei@openmailbox.org>2017-03-21 11:15:08 -0400
commit4b0e63670119971864289d67fc1e11a438f58ea6 (patch)
tree1244b9207324a64877c01cc3732d52e870fe72ae /gnu/packages/text-editors.scm
parented428a58ec347a9fb48aa75d805fab665f0eb6f4 (diff)
downloadguix-4b0e63670119971864289d67fc1e11a438f58ea6.tar.gz
gnu: Adjust asciidoc-related build options.
Commits 9099a45792306fade2d9ca55138e49ef4f01f1ea and
3078821d1380c26c738be6b5d430c595327d401f make many package inputs and
build configurations related to asciidoc obsolete.

* gnu/packages/compton.scm (compton)[inputs]: Remove docbook-xml,
libxml2 and libxslt.
* gnu/packages/mail.scm (offlinemap)[native-inputs]: Remove libxslt.
* gnu/packages/linux.scm (btrfs-progs)[native-inputs]: Remove docbook-xml.
(perf)[inputs]: Remove docbook-xml and libxslt.
* gnu/packages/text-editors.scm (kakoune)[native-inputs]: Remove libxslt.
* gnu/packages/version-control.scm (cgit)[native-inputs]: Remove
docbook-xml, docbook-xsl, libxml2 and libxslt.
(cvs-fast-export)[native-inputs]: Remove docbook-xml, docbook-xsl,
libxml2 and libxslt.
* gnu/packages/web.scm (qutebrowser)[native-inputs]: Remove docbook-xml,
docbook-xsl, libxml2, and libxslt.
(tinyproxy)[native-inputs]: Remove docbook-xml, docbook-xsl, libxml2 and
libxslt.
* gnu/packages/wm.scm (awesome)[make-flags]: Remove XML_CATALOG_FILES flag.
(i3-wm)[inputs]: Remove docbook-xml.
[native-inputs]: Add libxml2.
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm1
1 files changed, 0 insertions, 1 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 4b6aa07ee8..a093baa3bd 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -137,7 +137,6 @@ based command language.")
                ;; without them the tests fail.
                (zero? (system* "chmod" "-R" "u+w" "../test")))))))
       (native-inputs `(("gcc" ,gcc-5)
-                       ("libxslt" ,libxslt)
                        ("asciidoc" ,asciidoc)
                        ("ruby" ,ruby)))
       (inputs `(("gcc:lib" ,gcc-5 "lib")